Skaffa Premium för att gömma alla reklamer
Inlägg: 10   Besökt av: 111 users
13.10.2020 - 18:55
 Dave (Admin)
I've found and released an update to fix something that was causing the infamous "Websocket Closed" error.

For example, if you're working on a map, or just cloned a map, and when you save it immediately does this:

Citera:
Connection error: Error: WebSocket closed.
Connection is unstable. Attempting to reconnect...
Reconnected. Checking game state...
Reconnected. Resuming game...


.... and never actually saves. (Or perhaps you're playing a big game with many, many units and eventually it does the same thing...)

Well, I finally found the reason. To make it short... the problem was whenever the amount of data being saved exceeded a certain size, it would fail. That's why if you cloned a big map and it wouldn't save, but if you left out the units or something else then you could, you were in effect decreasing the size of the data to be saved. It wasn't anything to do with the units in particular, or the borders, or whatever, it was just the total size of all the data combined was over a certain limit. And that limit was not actually set by our code, so it was NOT obvious... it turned out to be a default limit set by one of the 3rd party libraries we rely on. Sheesh.

Further making this complicated was the fact that it failed silently.... it didn't give any real meaningful error to say "data size exceeded" or anything like that. It didn't log anything in our server logs. It basically was just "hey there was an error, I dunno why, lets close the connection cuz I dunno what else to do." Pretty silly, right?

Anyway, I fixed the size limit, so you should have no problems now cloning maps and saving maps of any size. If you had this problem with a map before, go ahead and give it a try now

(Note: there are still legitimate reasons you might see a "WebSocket closed" message, for example if you have a bad connection, but that's a different thing and obviously not something we can control...)

Cheers,
Dave
----
All men can see these tactics whereby I conquer,
but what none can see is the strategy out of which victory is evolved.
--Sun Tzu

Laddar...
Laddar...
13.10.2020 - 23:44
 nutt
----


Laddar...
Laddar...
14.10.2020 - 02:26
 Zoe
Mapmakers rn
----

dont you dare call me hoella
Laddar...
Laddar...
15.10.2020 - 02:04
Skrivet av Dave, 13.10.2020 at 18:55

if you cloned a big map and it wouldn't save, but if you left out the units or something else then you could, you were in effect decreasing the size of the data to be saved.

This explains a lot! Well done. When I was making Nova Aetas by cloning Colonial Empires, which is 6000x4500 in size with 284 countries, I was pissed off because I had to clone it while leaving behind all of the 254 units.

I wonder if this has anything to do with the editor freezing glitch that I wrote about here.
Laddar...
Laddar...
15.10.2020 - 04:09
Wish we had someone who know what he's doing
----
Laddar...
Laddar...
01.11.2020 - 17:25
Skrivet av Dave, 13.10.2020 at 18:55



So is the border glitch is gone now? I can save my borders and cities and they won't disappear when I test the map? Is that this fix?
----
Fuck the Chinese Communist Party and Fuck The World Health Organisation



Laddar...
Laddar...
01.11.2020 - 20:40
 Dave (Admin)
Skrivet av DeepFriedUnicorn, 01.11.2020 at 17:25

So is the border glitch is gone now? I can save my borders and cities and they won't disappear when I test the map? Is that this fix?


I have no idea. Try it and let me know
----
All men can see these tactics whereby I conquer,
but what none can see is the strategy out of which victory is evolved.
--Sun Tzu

Laddar...
Laddar...
20.11.2020 - 19:42
Skrivet av Dave, 01.11.2020 at 20:40

Skrivet av DeepFriedUnicorn, 01.11.2020 at 17:25

So is the border glitch is gone now? I can save my borders and cities and they won't disappear when I test the map? Is that this fix?


I have no idea. Try it and let me know


Just tried it, Its still not working.
Its Mesos problem that is sill here https://atwar-game.com/forum/topic.php?topic_id=44971

You either have to keep re uploading the background image to, fix? this issue. But even then, that doesn't work all of the time and is insanely tiresome to keep going in and out of testing the map and back into editing just to make sure the borders,cites and some cases units are still there, or have not duplicated

Im aware you have lots on your plate. But this/these strange bugs have been in the editor for 3 years now and is affecting different map makers in different ways
----
Fuck the Chinese Communist Party and Fuck The World Health Organisation



Laddar...
Laddar...
20.11.2020 - 20:18
 Dave (Admin)
Skrivet av DeepFriedUnicorn, 20.11.2020 at 19:42

Skrivet av Dave, 01.11.2020 at 20:40

Skrivet av DeepFriedUnicorn, 01.11.2020 at 17:25

So is the border glitch is gone now? I can save my borders and cities and they won't disappear when I test the map? Is that this fix?


I have no idea. Try it and let me know


Just tried it, Its still not working.
Its Mesos problem that is sill here https://atwar-game.com/forum/topic.php?topic_id=44971

You either have to keep re uploading the background image to, fix? this issue. But even then, that doesn't work all of the time and is insanely tiresome to keep going in and out of testing the map and back into editing just to make sure the borders,cites and some cases units are still there, or have not duplicated

Im aware you have lots on your plate. But this/these strange bugs have been in the editor for 3 years now and is affecting different map makers in different ways


I don't understand what issue you're describing here. Would you make a formal bug report for it, in the usual format (https://atwar-game.com/forum/topic.php?topic_id=39713) including the steps to reproduce, so I know what you're talking about?
----
All men can see these tactics whereby I conquer,
but what none can see is the strategy out of which victory is evolved.
--Sun Tzu

Laddar...
Laddar...
21.11.2020 - 14:55
Skrivet av Dave, 20.11.2020 at 20:18

Skrivet av DeepFriedUnicorn, 20.11.2020 at 19:42

Skrivet av Dave, 01.11.2020 at 20:40

Skrivet av DeepFriedUnicorn, 01.11.2020 at 17:25

So is the border glitch is gone now? I can save my borders and cities and they won't disappear when I test the map? Is that this fix?


I have no idea. Try it and let me know


Just tried it, Its still not working.
Its Mesos problem that is sill here https://atwar-game.com/forum/topic.php?topic_id=44971

You either have to keep re uploading the background image to, fix? this issue. But even then, that doesn't work all of the time and is insanely tiresome to keep going in and out of testing the map and back into editing just to make sure the borders,cites and some cases units are still there, or have not duplicated

Im aware you have lots on your plate. But this/these strange bugs have been in the editor for 3 years now and is affecting different map makers in different ways


I don't understand what issue you're describing here. Would you make a formal bug report for it, in the usual format (https://atwar-game.com/forum/topic.php?topic_id=39713) including the steps to reproduce, so I know what you're talking about?


Will do
----
Fuck the Chinese Communist Party and Fuck The World Health Organisation



Laddar...
Laddar...
atWar

About Us
Contact

Integritet | Användarvillkor | Bannare | Partners

Copyright © 2021 atWar. All rights reserved.

Följ oss på

sprid vidare